#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^!]+)($|!.*$)"
Local $sString = "aaaaa" & @CRLF & _
"aaa!bbbb" & @CRLF & _
"aaa!bbbb!cccc"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)