use strict;
my $str = 'aaaaa
aaa!bbbb
aaa!bbbb!cccc';
my $regex = qr/^([^!]+)($|!.*$)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";