package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^!]+)($|!.*$)`)
var str = `aaaaa
aaa!bbbb
aaa!bbbb!cccc`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}