re = /^([^!]+)($|!.*$)/m
str = 'aaaaa
aaa!bbbb
aaa!bbbb!cccc'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result