import re
regex = re.compile(r"^([^!]+)($|!.*$)", flags=re.MULTILINE)
test_str = ("aaaaa\n"
"aaa!bbbb\n"
"aaa!bbbb!cccc")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)