$re = '/^([^!]+)($|!.*$)/m';
$str = 'aaaaa
aaa!bbbb
aaa!bbbb!cccc';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;