#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!_|\d)(?!.*__)(?!.*_$)\w+$"
Local $sString = "_" & @CRLF & _
"A" & @CRLF & _
"abcd" & @CRLF & _
"_" & @CRLF & _
"123" & @CRLF & _
"some_spaces " & @CRLF & _
"not_any_spaces__" & @CRLF & _
"1test34" & @CRLF & _
"correct_thing"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")