re = /^(?!_|\d)(?!.*__)(?!.*_$)\w+$/m
str = '_
A
abcd
_
123
some_spaces
not_any_spaces__
1test34
correct_thing'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end