$re = '/^(?!_|\d)(?!.*__)(?!.*_$)\w+$/m';
$str = '_
A
abcd
_
123
some_spaces
not_any_spaces__
1test34
correct_thing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);