using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!_|\d)(?!.*__)(?!.*_$)\w+$";
string input = @"_
A
abcd
_
123
some_spaces
not_any_spaces__
1test34
correct_thing";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}