const regex = /^(?!_|\d)(?!.*__)(?!.*_$)\w+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!_|\\d)(?!.*__)(?!.*_$)\\w+$', 'gm')
const str = `_
A
abcd
_
123
some_spaces
not_any_spaces__
1test34
correct_thing`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}