import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!_|\\d)(?!.*__)(?!.*_$)\\w+$";
final String string = "_\n"
+ "A\n"
+ "abcd\n"
+ "_\n"
+ "123\n"
+ "some_spaces \n"
+ "not_any_spaces__\n"
+ "1test34\n"
+ "correct_thing";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}