#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^(.*?)\s*#flashcard\n([^:]+):.*?^(\S[^\n]+)\s+(?:---|<!--)"
Local $sString = "How do we achieve A? #flashcard" & @CRLF & _
"To achieve A we need to do the following:" & @CRLF & _
"" & @CRLF & _
"Do B" & @CRLF & _
"" & @CRLF & _
"Do C" & @CRLF & _
"" & @CRLF & _
"Finally do D" & @CRLF & _
"" & @CRLF & _
"---" & @CRLF & _
"How do we achieve W? #flashcard" & @CRLF & _
"To achieve W we need to do the following:" & @CRLF & _
"" & @CRLF & _
"Do Y" & @CRLF & _
"" & @CRLF & _
"Do Z" & @CRLF & _
"" & @CRLF & _
"<!--" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")