const regex = /^(.*?)\s*#flashcard\n([^:]+):.*?^(\S[^\n]+)\s+(?:---|<!--)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)\\s*#flashcard\\n([^:]+):.*?^(\\S[^\\n]+)\\s+(?:---|<!--)', 'gms')
const str = `How do we achieve A? #flashcard
To achieve A we need to do the following:
Do B
Do C
Finally do D
---
How do we achieve W? #flashcard
To achieve W we need to do the following:
Do Y
Do Z
<!--
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}