use strict;
my $str = 'How do we achieve A? #flashcard
To achieve A we need to do the following:
Do B
Do C
Finally do D
---
How do we achieve W? #flashcard
To achieve W we need to do the following:
Do Y
Do Z
<!--
';
my $regex = qr/^(.*?)\s*#flashcard\n([^:]+):.*?^(\S[^\n]+)\s+(?:---|<!--)/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}