re = /^(.*?)\s*#flashcard\n([^:]+):.*?^(\S[^\n]+)\s+(?:---|<!--)/m
str = 'How do we achieve A? #flashcard
To achieve A we need to do the following:
Do B
Do C
Finally do D
---
How do we achieve W? #flashcard
To achieve W we need to do the following:
Do Y
Do Z
<!--
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end