using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)\s*#flashcard\n([^:]+):.*?^(\S[^\n]+)\s+(?:---|<!--)";
string input = @"How do we achieve A? #flashcard
To achieve A we need to do the following:
Do B
Do C
Finally do D
---
How do we achieve W? #flashcard
To achieve W we need to do the following:
Do Y
Do Z
<!--
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}