import Foundation
let pattern = ##"^(.*?)\s*#flashcard\n([^:]+):.*?^(\S[^\n]+)\s+(?:---|<!--)"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = ##"""
How do we achieve A? #flashcard
To achieve A we need to do the following:
Do B
Do C
Finally do D
---
How do we achieve W? #flashcard
To achieve W we need to do the following:
Do Y
Do Z
<!--
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)