package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9]{2,3})([\s.-]?)([0-9]{3,4})([\s.-]?)([0-9]{4})$`)
var str = `55 1234 5678
614 123 4567
1234568791
55 555 5555
32 1123 3212 9999
asdasdasda
// For Mexico check length
if(chosenRegex === phoneMx) {
const phoneMxLenght = $.trim(value.replace(/[\s.-]?/g, '')).length;
if (phoneMxLenght !== 10) {
this.error = this.labels.errors.format;
return;
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}