const regex = /^([0-9]{2,3})([\s.-]?)([0-9]{3,4})([\s.-]?)([0-9]{4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9]{2,3})([\\s.-]?)([0-9]{3,4})([\\s.-]?)([0-9]{4})$', 'gm')
const str = `55 1234 5678
614 123 4567
1234568791
55 555 5555
32 1123 3212 9999
asdasdasda
// For Mexico check length
if(chosenRegex === phoneMx) {
const phoneMxLenght = \$.trim(value.replace(/[\\s.-]?/g, '')).length;
if (phoneMxLenght !== 10) {
this.error = this.labels.errors.format;
return;
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}