import re
regex = re.compile(r"^([0-9]{2,3})([\s.-]?)([0-9]{3,4})([\s.-]?)([0-9]{4})$", flags=re.MULTILINE)
test_str = ("55 1234 5678\n"
"614 123 4567\n"
"1234568791\n"
"55 555 5555\n"
"32 1123 3212 9999\n"
"asdasdasda\n\n\n"
"// For Mexico check length\n"
"if(chosenRegex === phoneMx) {\n"
" const phoneMxLenght = $.trim(value.replace(/[\\s.-]?/g, '')).length;\n"
" if (phoneMxLenght !== 10) {\n"
" this.error = this.labels.errors.format;\n"
" return;\n"
" }\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")