re = /^([0-9]{2,3})([\s.-]?)([0-9]{3,4})([\s.-]?)([0-9]{4})$/m
str = '55 1234 5678
614 123 4567
1234568791
55 555 5555
32 1123 3212 9999
asdasdasda
// For Mexico check length
if(chosenRegex === phoneMx) {
const phoneMxLenght = $.trim(value.replace(/[\\s.-]?/g, \'\')).length;
if (phoneMxLenght !== 10) {
this.error = this.labels.errors.format;
return;
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end