use strict;
my $str = '55 1234 5678
614 123 4567
1234568791
55 555 5555
32 1123 3212 9999
asdasdasda
// For Mexico check length
if(chosenRegex === phoneMx) {
const phoneMxLenght = $.trim(value.replace(/[\\s.-]?/g, \'\')).length;
if (phoneMxLenght !== 10) {
this.error = this.labels.errors.format;
return;
}
}';
my $regex = qr/^([0-9]{2,3})([\s.-]?)([0-9]{3,4})([\s.-]?)([0-9]{4})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}