#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bMS\b"
Local $sString = "MS-05B" & @CRLF & _
"05B-MS" & @CRLF & _
"ザク MS 05B" & @CRLF & _
"(旧ザク)MS-05B ザクI" & @CRLF & _
"MS: 05B" & @CRLF & _
";MS;" & @CRLF & _
""MS"" & @CRLF & _
"'MS'" & @CRLF & _
"MS.MS,MS" & @CRLF & _
"[MS]" & @CRLF & _
"{MS}" & @CRLF & _
"" & @CRLF & _
"MS -- 改行は境界扱い" & @CRLF & _
"" & @CRLF & _
"(MS) -- 全角記号は境界扱い" & @CRLF & _
"{MS}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"-- 数値は境界扱いされない" & @CRLF & _
"001MS999" & @CRLF & _
"-- 非アルファベット文字が境界扱いされる(PCRE/JS/Python/Golang)" & @CRLF & _
"ザクMSザク" & @CRLF & _
"量産MS量産"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")