using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bMS\b";
string input = @"MS-05B
05B-MS
ザク MS 05B
(旧ザク)MS-05B ザクI
MS: 05B
;MS;
""MS""
'MS'
MS.MS,MS
[MS]
{MS}
MS -- 改行は境界扱い
(MS) -- 全角記号は境界扱い
{MS}
-- 数値は境界扱いされない
001MS999
-- 非アルファベット文字が境界扱いされる(PCRE/JS/Python/Golang)
ザクMSザク
量産MS量産";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}