import re
regex = re.compile(r"\bMS\b", flags=re.MULTILINE)
test_str = ("MS-05B\n"
"05B-MS\n"
"ザク MS 05B\n"
"(旧ザク)MS-05B ザクI\n"
"MS: 05B\n"
";MS;\n"
"\"MS\"\n"
"'MS'\n"
"MS.MS,MS\n"
"[MS]\n"
"{MS}\n\n"
"MS -- 改行は境界扱い\n\n"
"(MS) -- 全角記号は境界扱い\n"
"{MS}\n\n\n"
"-- 数値は境界扱いされない\n"
"001MS999\n"
"-- 非アルファベット文字が境界扱いされる(PCRE/JS/Python/Golang)\n"
"ザクMSザク\n"
"量産MS量産")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")