import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bMS\\b";
final String string = "MS-05B\n"
+ "05B-MS\n"
+ "ザク MS 05B\n"
+ "(旧ザク)MS-05B ザクI\n"
+ "MS: 05B\n"
+ ";MS;\n"
+ "\"MS\"\n"
+ "'MS'\n"
+ "MS.MS,MS\n"
+ "[MS]\n"
+ "{MS}\n\n"
+ "MS -- 改行は境界扱い\n\n"
+ "(MS) -- 全角記号は境界扱い\n"
+ "{MS}\n\n\n"
+ "-- 数値は境界扱いされない\n"
+ "001MS999\n"
+ "-- 非アルファベット文字が境界扱いされる(PCRE/JS/Python/Golang)\n"
+ "ザクMSザク\n"
+ "量産MS量産";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}