// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bMS\b").unwrap();
let string = "MS-05B
05B-MS
ザク MS 05B
(旧ザク)MS-05B ザクI
MS: 05B
;MS;
\"MS\"
'MS'
MS.MS,MS
[MS]
{MS}
MS -- 改行は境界扱い
(MS) -- 全角記号は境界扱い
{MS}
-- 数値は境界扱いされない
001MS999
-- 非アルファベット文字が境界扱いされる(PCRE/JS/Python/Golang)
ザクMSザク
量産MS量産";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}