#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\/\*.*?):this\s*\{[^}]+\}"
Local $sString = " :this { " & @CRLF & _
" display: grid; " & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" p { color: red}" & @CRLF & _
"" & @CRLF & _
" :this { this is also okay to capture }" & @CRLF & _
" /* but do not capture this :this { } , so how to look far behind here */" & @CRLF & _
" :this { " & @CRLF & _
" display: grid; " & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" p { color: red}" & @CRLF & _
"" & @CRLF & _
" :this { this is also okay to capture }" & @CRLF & _
" /* but do not capture this :this { } , so how to look far behind here */"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")