import re
regex = re.compile(r"(?<!\/\*.*?):this\s*\{[^}]+\}")
test_str = (" :this { \n"
" display: grid; \n"
" }\n\n"
" p { color: red}\n\n"
" :this { this is also okay to capture }\n"
" /* but do not capture this :this { } , so how to look far behind here */\n"
" :this { \n"
" display: grid; \n"
" }\n\n"
" p { color: red}\n\n"
" :this { this is also okay to capture }\n"
" /* but do not capture this :this { } , so how to look far behind here */")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")