$re = '/(?<!\/\*.*?):this\s*\{[^}]+\}/';
$str = ' :this {
display: grid;
}
p { color: red}
:this { this is also okay to capture }
/* but do not capture this :this { } , so how to look far behind here */
:this {
display: grid;
}
p { color: red}
:this { this is also okay to capture }
/* but do not capture this :this { } , so how to look far behind here */';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);