import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\/\\*.*?):this\\s*\\{[^\\}]+\\}";
final String string = " :this { \n"
+ " display: grid; \n"
+ " }\n\n"
+ " p { color: red}\n\n"
+ " :this { this is also okay to capture }\n"
+ " /* but do not capture this :this { } , so how to look far behind here */\n"
+ " :this { \n"
+ " display: grid; \n"
+ " }\n\n"
+ " p { color: red}\n\n"
+ " :this { this is also okay to capture }\n"
+ " /* but do not capture this :this { } , so how to look far behind here */";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}