re = /(?<!\/\*.*?):this\s*\{[^}]+\}/
str = ' :this {
display: grid;
}
p { color: red}
:this { this is also okay to capture }
/* but do not capture this :this { } , so how to look far behind here */
:this {
display: grid;
}
p { color: red}
:this { this is also okay to capture }
/* but do not capture this :this { } , so how to look far behind here */'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end