using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(01\d{14})(17\d{6})?(10\w{1,20})?(21\w{1,20})?$";
string input = @"01084700069811461719010010285322921DA192089940088
01084700088763891719050010BM2120
Each block start with a fixed code and is followed by digits o characters
01 + 14 digits
17 + 6 digits
10 + from 1 to 20 characters
21 + from 1 to 20 characters
0108470006981146 17190100 102853229 21DA192089940088
0108470008876389 17190500 10BM2120";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}