$re = '/^(01\d{14})(17\d{6})?(10\w{1,20})?(21\w{1,20})?$/m';
$str = '01084700069811461719010010285322921DA192089940088
01084700088763891719050010BM2120
Each block start with a fixed code and is followed by digits o characters
01 + 14 digits
17 + 6 digits
10 + from 1 to 20 characters
21 + from 1 to 20 characters
0108470006981146 17190100 102853229 21DA192089940088
0108470008876389 17190500 10BM2120';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);