const regex = /^(01\d{14})(17\d{6})?(10\w{1,20})?(21\w{1,20})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(01\\d{14})(17\\d{6})?(10\\w{1,20})?(21\\w{1,20})?$', 'gm')
const str = `01084700069811461719010010285322921DA192089940088
01084700088763891719050010BM2120
Each block start with a fixed code and is followed by digits o characters
01 + 14 digits
17 + 6 digits
10 + from 1 to 20 characters
21 + from 1 to 20 characters
0108470006981146 17190100 102853229 21DA192089940088
0108470008876389 17190500 10BM2120`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}