import Foundation
let pattern = #"^(01\d{14})(17\d{6})?(10\w{1,20})?(21\w{1,20})?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
01084700069811461719010010285322921DA192089940088
01084700088763891719050010BM2120
Each block start with a fixed code and is followed by digits o characters
01 + 14 digits
17 + 6 digits
10 + from 1 to 20 characters
21 + from 1 to 20 characters
0108470006981146 17190100 102853229 21DA192089940088
0108470008876389 17190500 10BM2120
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)