import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(01\\d{14})(17\\d{6})?(10\\w{1,20})?(21\\w{1,20})?$";
final String string = "01084700069811461719010010285322921DA192089940088\n"
+ "01084700088763891719050010BM2120\n\n"
+ "Each block start with a fixed code and is followed by digits o characters\n\n"
+ "01 + 14 digits\n"
+ "17 + 6 digits\n"
+ "10 + from 1 to 20 characters\n"
+ "21 + from 1 to 20 characters\n\n"
+ "0108470006981146 17190100 102853229 21DA192089940088\n\n"
+ "0108470008876389 17190500 10BM2120";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}