package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`SN=([A-Z]+:[\d-]+):`)
var str = `SIGN="000F 0E70 FA83 B72F D215 C7EE 4AF4 6440 A547 12B1 0603 \
SN=RK:7573-0:2832397:369963
1086 0857 BFF1 5FC2 CE6F C87D 7C00 DF64 C1AD DD39") }`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}