// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"SN=([A-Z]+:[\d-]+):").unwrap();
let string = "SIGN=\"000F 0E70 FA83 B72F D215 C7EE 4AF4 6440 A547 12B1 0603 \\
SN=RK:7573-0:2832397:369963
1086 0857 BFF1 5FC2 CE6F C87D 7C00 DF64 C1AD DD39\") }";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}