using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([01]\d|[0-9]|2[0-3]):?([0-5]\d)$";
string input = @"02:00
22:00
23:59
00:00
24:00
9:30
2:30";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}