$re = '/^([01]\d|[0-9]|2[0-3]):?([0-5]\d)$/m';
$str = '02:00
22:00
23:59
00:00
24:00
9:30
2:30';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);