// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([01]\d|[0-9]|2[0-3]):?([0-5]\d)$").unwrap();
let string = "02:00
22:00
23:59
00:00
24:00
9:30
2:30";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}