import re
regex = re.compile(r"^([01]\d|[0-9]|2[0-3]):?([0-5]\d)$", flags=re.MULTILINE)
test_str = ("02:00\n"
"22:00\n"
"23:59\n"
"00:00\n"
"24:00\n"
"9:30\n"
"2:30")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")