package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([01]\d|[0-9]|2[0-3]):?([0-5]\d)$`)
var str = `02:00
22:00
23:59
00:00
24:00
9:30
2:30`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}