using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([a-zA-Z0-9]*)(?:\s*,\s*([a-zA-Z0-9]*))*)";
string input = @"a1, a2, a3, a4, a5, a6";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}