package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([a-zA-Z0-9]*)(?:\s*,\s*([a-zA-Z0-9]*))*)`)
var str = `a1, a2, a3, a4, a5, a6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}