$re = '/(([a-zA-Z0-9]*)(?:\s*,\s*([a-zA-Z0-9]*))*)/m';
$str = 'a1, a2, a3, a4, a5, a6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);