re = /(([a-zA-Z0-9]*)(?:\s*,\s*([a-zA-Z0-9]*))*)/m
str = 'a1, a2, a3, a4, a5, a6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end