# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,(?=[^"]+")/-/g;t' <<< "728,\"H !A@Y,HAYE\",Marie,François,RAUTUREAU,85,29/05/1856,68;"